Back to overview
Downtime
MySB2 is currently unavailable
May 22 at 11:53am AEST
Affected services
MySB2
Resolved
May 22 at 12:28pm AEST
We've identified the root cause of the issue and have taken steps to prevent it from happening again. Thank you for your patience and understanding. All invoice jobs will be run within the next few hours.
Affected services
MySB2
Created
May 22 at 11:53am AEST
We're investigating the outage of the MySB2 platform. Engineers will provide updates as they become available.
Affected services
MySB2